Cisco a volte è fantastica! Capisco che i suoi prodotti siano configurabili da linea di comando, ma per fare un router per EOLO di fatto basta inserire il PPPOE e l’SDM express (quello accessibile via web senza software installato, quindi anche da MAC) o l’SDM “full” (quello accessibile sempre via web ma solo se hai installato il sw su una macchina windows) hanno un errore !!! lanciano un comando (pppoe enable) che sulle ultime versioni di IOS (il sistema operativo dei router Cisco) non è più disponibile / necessario.

Inutile dire che l’alternativa alla linea di comando, ovvero il software “Cisco Configuration Professional” non è disponibile sul cd in dotazione con il router, ma scaricabile solo previa registrazione dal sito cisco a questo indirizzo:

http://www.cisco.com/en/US/products/ps9422/index.html

E’ però fondamentale avere una versione di IOS pari o superiore a quella indicata nella tabella delle specifiche, visualizzabili a questa pagina:

http://www.cisco.com/en/US/prod/collateral/routers/ps9422/data_sheet_c78_462210.htm

E per scaricare il firmware nuovo … dovrete registrarvi sul sito e, soprattutto … acquistare un canone di manutenzione (poche decine di euro … ma comunque una cosa illogica)

Una volta ottenuto il file .bin del nuovo IOS … non vi resta che installarlo da linea di comando prelevandolo da un server tftp (consiglio tftpd32, un progetto open source) sulla vostra rete.

Non sapete come procedere? Vi segnalo queste (lunghe ma complete) istruzioni, valide anche per i router della serie 850:

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a00801fc986.shtml

(usate le istruzioni relative alla copia in flash del file) ;)

Devo dire che per prodotti di questo livello un errore come questo è veramente sorprendente. Potrei capire il cd “sbagliato”, ma il software di configurazione via web inserito nel router non può non sapere che il comando di abilitazione del pppoe non va più passato. Sapete qual è la cosa più assurda? Che se fate la procedura utilizzando il wizard obbligatorio quando usate l’SMD express e attivate il pppoe … l’interfaccia wan si incasina e di fatto non è più riconfigurabile con l’SDM, nè express, nè full … va resettato o fatto da linea di comando!

Noi non finiamo mai di imparare, e questo può esser positivo … ma i produttori non finiscono mai di complicarci la vita, e questo non lo è affatto! ;)