In questi giorni ci ha fatto dannare un problema del nuovo exchange 2010:

cliente con Exchange 2003 su porta https non standard (nell’esempio era la 447): via web (owa) tutto va bene. Aggiorniamo al 2010 e … Boing! Si accede, tutto sembra funzionare, ma … le mail non si cancellano !!! Errore 108 negli eventi di sistema. Rapida ricerca online e … GULP! E’ documentato un po’ ovunque: Exchange 2010 mal tollera il cambio porta, poiché la 443 e la 80 (le porte di default) sono scritte nel codice e alcune funzioni (quali la cancellazione delle mail) non vanno. Onestamente mi sembra strano, ma tutte le ricerche portano agli stessi risultati.

Beh, oggi finalmente la soluzione (un po’ folle, ma funziona!)

– lasciare il binding del default website sulle porte standard (443 / 80)
– creare un nuovo website in IIS (puntiamolo pure ad una directory vuota) (nell’esempio lo chiamiamo owa2)
– aprire la shell di exchange e creare una nuova virtual directory per owa con il comando New-OwaVirtualDirectory -WebSiteName “owa2”
– al termine verrà suggerito di creare anche una nuova virtualdir ecp (Exchange Control Panel) per questo sito, farlo quindi con il comando NewEcpVirtualDirectory -WebSiteName “owa2”
– ricordatevi che se avete dei device mobile (iPhone, x esempio) connessi via active sync dovete anche creare la relativa virtual dir, con il comando: New-ActiveSyncVirtualDirectory -WebSiteName “owa2”

Et voilà, il gioco è fatto, owa sulla 447 (anche sulla 443 a dire il vero) con le mail che si cancellano

Più passa il tempo e più mi convinco che Kerio rulez !!! ;) Costa molto meno ed è drammaticamente più facile! :)